Front pump PSI

All Models and Years
Post Reply
albjerryg
Posts: 63
Joined: Wed Dec 18, 2019 1:55 am

Front pump PSI

Post by albjerryg »

Here are the Front Pump in PSI. The top one is at idle and the bottom one is at idle with no vacuum . The reading of 200psi in reverse is a guess my gauge only up to 160 and it pegged out. I have no idea what it all means but maybe some can help. Thanks Jerry
Corvair 28.JPG
Corvair 28.JPG (21.42 KiB) Viewed 117 times

albjerryg
Posts: 63
Joined: Wed Dec 18, 2019 1:55 am

Re: Front pump PSI

Post by albjerryg »

Probably means I need to rebuild the transmission. Jerry

albjerryg
Posts: 63
Joined: Wed Dec 18, 2019 1:55 am

Re: Front pump PSI

Post by albjerryg »

Corvair 29.JPG
Corvair 29.JPG (31.83 KiB) Viewed 88 times
I have included both the readings and what the book says they should be in hope some one can make a suggestion about what the problem could be. Thanks Jerry
Corvair 30.JPG
Corvair 30.JPG (21.45 KiB) Viewed 88 times

joelsplace
Posts: 944
Joined: Wed Oct 13, 2010 12:51 pm
Location: Northlake, TX

Re: Front pump PSI

Post by joelsplace »

That means a leak in the first gear circuit. Probably hard seals. You could try some Trans-x to soften the seals but that is just a band-aid.
114 Corvairs, 5 Ultravans and counting
Northlake, TX

albjerryg
Posts: 63
Joined: Wed Dec 18, 2019 1:55 am

Re: Front pump PSI

Post by albjerryg »

Yes I have already tried Trans-X. Also I should mention that the car was blocked up and as I went through the gears R-N-D the idle increase a little but when I went to L the idle went way up?????Thanks Jerry

joelsplace
Posts: 944
Joined: Wed Oct 13, 2010 12:51 pm
Location: Northlake, TX

Re: Front pump PSI

Post by joelsplace »

Forget what I said. I just noticed the no vacuum first gear pressure is fine. According to the book numbers the modulator is bypassed when in manual first. If that is correct you'll need a fluid diagram to figure out what valve should bypass the modulator and look there. You should be able to fix that problem in the valve body.
114 Corvairs, 5 Ultravans and counting
Northlake, TX

albjerryg
Posts: 63
Joined: Wed Dec 18, 2019 1:55 am

Re: Front pump PSI

Post by albjerryg »

I guess that means I need to remove the transmission. Thanks for your help>>>>>>Jerry

joelsplace
Posts: 944
Joined: Wed Oct 13, 2010 12:51 pm
Location: Northlake, TX

Re: Front pump PSI

Post by joelsplace »

No. The valve body is under the pan.
114 Corvairs, 5 Ultravans and counting
Northlake, TX

albjerryg
Posts: 63
Joined: Wed Dec 18, 2019 1:55 am

Re: Front pump PSI

Post by albjerryg »

Thanks for the help . Jerrry

Post Reply

Return to “Ask your Mechanical Questions here”