Search found 110 matches

by eForce
Wed Sep 27, 2017 6:02 pm
Forum: Corvair Talk
Topic: Stalling
Replies: 3
Views: 498

Re: Stalling

I didn't hook up a light but I went full advance to full retarded in small increments. same issue at all positions.
by eForce
Wed Sep 27, 2017 4:26 pm
Forum: Corvair Talk
Topic: Stalling
Replies: 3
Views: 498

Stalling

Okay so I went to an out of town car show and then a local show last night. Ran great. Today, it fires right up but dies when I put it in gear. I didn't see the vacuum advance move so I replaced that and same thing. Can't see or hear any vacuum leaks. It's getting fuel. Once I rev it up, it's fine. ...
by eForce
Wed Jun 07, 2017 5:29 pm
Forum: Corvair Talk
Topic: Knocking and Pinging
Replies: 16
Views: 996

Re: Knocking and Pinging

FIXED! My whole issue all along was the accelerator linkage at the tranny. I finally had a chance to look at another corsair and set it up properly and voila...runs awesome. Still gets very hot but that may be because I haven't got my front exhaust heat tubes on yet. Then I was able to sync carbs pr...
by eForce
Wed May 17, 2017 6:23 am
Forum: Corvair Talk
Topic: Knocking and Pinging
Replies: 16
Views: 996

Re: Knocking and Pinging

Update...I pulled carbs and reassembled with a basic starting point for syncronization. I also replaced the O-Rings on my push rod tubes as they leaked when it got hot. I noticed that I had 3 push rods in backwards. Interesting, however, knocking and pinging is gone. Not sure if the push rods had an...
by eForce
Sun Apr 23, 2017 3:48 pm
Forum: Corvair Talk
Topic: Knocking and Pinging
Replies: 16
Views: 996

Re: Knocking and Pinging

Yes, I looked that up and put the vacuum advance back on the vertical port. I got vacuum up to 11 with curb idle. Compression is 150. Timing is at 10 deg. If I go more...the knocking comes back. I did replace the wires because I seemed to have a weak spark. That helped out quite a bit but now I've m...
by eForce
Sun Apr 23, 2017 8:05 am
Forum: Corvair Talk
Topic: Knocking and Pinging
Replies: 16
Views: 996

Re: Knocking and Pinging

ok so I set the timing properly. It was out a bit but not much. 2ndly I adjusted my chokes. Still knocked when it warmed up. My vacuum advance is hooked up to the top port so I tested it and my vacuum was at 9. I then tested the bottom port and that was 10 so I moved the vacuum advance to that port ...
by eForce
Tue Apr 18, 2017 5:36 pm
Forum: Corvair Talk
Topic: Knocking and Pinging
Replies: 16
Views: 996

Re: Knocking and Pinging

agreed but why would it run so great with no knocks when it's cold?
by eForce
Tue Apr 18, 2017 5:19 pm
Forum: Corvair Talk
Topic: Knocking and Pinging
Replies: 16
Views: 996

Knocking and Pinging

Hi guys. Finished replacing the head on the drivers side. Got the motor built and reinstalled. Runs WAY better than before. As long as it's cold. The problem is, once it warms up AND I'm at idle in drive, it knocks and pings like crazy. Once I give it a little gas, it runs great again. Any ideas? I'...
by eForce
Sun Feb 05, 2017 8:27 pm
Forum: Ask your Mechanical Questions here
Topic: Should I do it fellas?
Replies: 14
Views: 803

Re: Should I do it fellas?

Mine sat outside for 12 years and was flooded


Sent from my iPhone using Corvair Forum mobile app
by eForce
Sat Feb 04, 2017 6:09 am
Forum: Corvair Talk
Topic: Is this body worth saving?
Replies: 6
Views: 691

Re: Is this body worth saving?

Outter panels are an easy fix and cheap. For down below, make sure the inner panel is solid as that is your structure (being a unibody)

If solid, fix the panels. Mine was way worse. In fact I made one fender with a hammer and chisel


Sent from my iPhone using Corvair Forum mobile app
by eForce
Sat Feb 04, 2017 4:57 am
Forum: Ask your Mechanical Questions here
Topic: I used the battery everyone uses and it don't work!
Replies: 32
Views: 1491

Re: I used the battery everyone uses and it don't work!

Check your ground strap to chassis. You will find corrosion which is causing heavy resistance


Sent from my iPhone using Corvair Forum mobile app
by eForce
Thu Oct 20, 2016 5:16 am
Forum: Corvair Talk
Topic: Engine Cranks Slowly
Replies: 22
Views: 1053

Re: Engine Cranks Slowly

ok. Success finally! The power issue was my gas pedal. I finally got some over to step on the gas while I observed carbs. Butterflies were only opening 15 deg. Pulled pedal and saw that this has been an issue before as someone welded the bracket to the rod behind the pedal and it broke loose. Likely...
by eForce
Mon Oct 17, 2016 3:08 pm
Forum: Corvair Talk
Topic: Engine Cranks Slowly
Replies: 22
Views: 1053

Re: Engine Cranks Slowly

Timing is way advanced. Here is my compression. What is up with cylinder 5?

https://1drv.ms/f/s!Al5viGJMAfhzgQKpGAUTtg01uR3f
by eForce
Mon Oct 17, 2016 10:57 am
Forum: Corvair Talk
Topic: Engine Cranks Slowly
Replies: 22
Views: 1053

Re: Engine Cranks Slowly

ok, put new o rings on and voila. No oil leak. Now, it continues. Took it for a drive and it has NO power. NO kickdown. AArrgghh! Also has a funny response. Give it gas and it revs up but stays that way for a second or two before coming to idle. I'm still suspecting the cable linkage for the respons...
by eForce
Mon Oct 10, 2016 5:34 am
Forum: Corvair Talk
Topic: Engine Cranks Slowly
Replies: 22
Views: 1053

Re: Engine Cranks Slowly

Ok thanks. I'll wait till next week when I'm on holidays. Need a break from it


Sent from my iPhone using Corvair Forum mobile app
by eForce
Sun Oct 09, 2016 4:41 am
Forum: Corvair Talk
Topic: Engine Cranks Slowly
Replies: 22
Views: 1053

Rebuild saga

Lastly. regarding the accelerator rod linkage...if I connect it from the outside, the rod gets stuck on the rod that goes up to the carbs so I connected it from the inside. Anyone have a pic of a proper setup? Aarrgghhh! After all that, went to go for a drive cause it runs great but noticed tons of ...

Go to advanced search